更新WordPress 2.9 导致 Simple Tags 插件过期解决办法

2.9 提示:

Simple Tags can’t work with this WordPress version!

其实也算不上不兼容,是插件作者多了一个 WordPress 版本强行检查的注释,最高版本检查 wp 2.8 已经写死(hard-coded)在里面了,还没来得及更新。解决方法,只要找到 simple-tags.php:
修改if ( strpos($wp_version, '2.7') !== false || strpos($wp_version, '2.8') !== false )
if ( strpos($wp_version, '2.7') !== false || strpos($wp_version, '2.9') !== false )

发表评论